RIP GrowlVoice. You shall be missed.

I’ve used a little menu bar app called GrowlVoice for a very long time. It let me send/receive SMS messages and phone calls from my computer, without having to have an app open in the dock, and was generally very handy. However, it seems that there was a recent change in the GrowlVoice setup, and the app has stopped working for me (it appears to still be working for some others). It throws a JSON error at startup, and just… sits there, lost and forlorn. The little bit of information that I’ve been able to glean from the Interwebs indicates that the developer is no longer going to be supporting the app.

Well, crap.

I’ve installed Google Voice for Chrome, but… the app won’t acknowledge that I already have a Google Voice account. I suspect that this has something to do with the fact that I’m logged in with two Google accounts in Chrome. I’ve tried logging out of both accounts, and then only logging in with the one that’s actually associated with Google Voice, but no luck. I just keep getting the little “The Chrome extension only works with Google Voice accounts that use a Google Voice number or use voicemail,” popup, along with a link to get a Google Voice number. Of course, when I click on the link, it loads my Google Voice account. Grrr.

Once, just once, Google Voice for Chrome notified me of an incoming SMS. “Huzzah!” thought I, thinking that maybe the magical world of conflicting cookies had worked themselves out. And they had… kinda. It seems the extension is now in “Client Only” mode, and cannot initiate anything (such as responding to an SMS, or making a phone call), just receive. It’s taunting me!


So now I’m trying VoiceMac by someone who calls himself Mr. Gecko. It’s … functional, but not nearly as polished as either GrowlVoice was or (from what I’ve seen of G’s install) Google Voice for Chrome is.

Anyone else have any suggestions for an app to replace GrowlVoice? Or hints on how to get the Google Voice for Chrome extension to work reasonably?

TLD madness. Or, “This .land is your .land, this .land is my .land.”

It would seem that there are a bunch of new TLDs available. And really, some most of them are just silly. Reading them, and imagining an actual domain, they read more like USENET (remember that?) group names. (I have to admit, I’m really tempted to make that happen.) (For Amiga users everywhere.)

The possibilities are endless. And kinda dumb.

Dear LazyWeb: Why does my (i)phone hate me?

It’s true. My phone has definitely developed an attitude since installing iOS 7. However, the greatest trouble I’m having of late is that I am unable to install anything from the App Store. Since this is, you know, the easiest way to get new things onto my phone, I’m kind of displeased.

I go to the App Store, and find something I want to buy. I press the little icon with the price, which then converts to “Buy.” I then press the “Buy” button. In the past, this has usually changed the little button into a swirling circle thing, then after a few seconds, I’ll get a password prompt. Once I enter my password correctly, the swirling circle thing starts to fill in, showing installation progress. At least, that’s how it *used* to work.

Now, I press the “Buy” button, and get the swirling circle thing and… that’s it. No password prompt, no filling circle, nothing. It just sits there, forever. (Or until the screen locks, but it’s in the same state once I unlock the screen.) (Or until I press the home button.)

I’ve done a couple of quick searches, and they mostly lead me to people who can’t type their password. I never even get that far.

This is on an iPhone 4S. Yes, I’ve rebooted the phone. No, I haven’t tried completely wiping it. I was hoping to avoid that.

Any thoughts?

PSA: Adobe Customer Security Alert.

I received this mail from Adobe this morning, and thought I’d share, in case anyone has the mail going to the bit bucket. (more…)

Kindle feature request.

(Hey, the last thing I wished for with regard to the Kindle came true, so who knows?)

I’m on something like my 4th Kindle. Nothing’s been wrong with any of them. I just somehow keep upgrading. *waves hands* That’s not the point.

The point is, I am really really tired of having to re-download all of my content to my device every time I upgrade. I have over 1,000 Kindle titles. I do not want to have to individually download all of these things every time I switch devices. Can someone poke Jeff Bezos and ask him to make a bulk action tool on the “Manage Your Kindle” page?


This morning’s annoyance.

I have this Excel spreadsheet. Believe it or not, that is not, in and of itself, the annoyance.

I have data in columns A & B, and column C consists of this formula:

=if(countblank($a2:$b2)=0,concatenate($b2, ", §", $a2), "")

This works perfectly, with one small exception: the formatting in cell $b2 (partial italics) is lost in the concatenation. Since I have a few hundred rows to deal with, hand-formatting (again, since I originally hand-formatted $b2 to begin with) is really annoying.

Yes, I know that Excel isn’t a word processor, and that formatting is for word processors. But, damnit, this should work.

Mac OS X Special Character Quick Reference

I was chatting with someone today, and mentioned that the heat index was 106°. My correspondent immediately asked me how I managed to make the degree symbol. As I’m on a Mac, it’s dead simple: option-shift-8. This was something of a revelation to my friend (also a Mac user), and the next question was, “What other cool symbols can I type!?”

Instead of doing the right thing (telling my friend to open a TextEdit document and try the damned keyboard combinations), I made a cheat sheet. (Only about halfway through making it did it occur to me to Google for one. And by then, I was already invested in the damned thing.)

So, if any of you might find it handy, here it is: OS X Special Character Quick Reference

Enjoy. Or don’t. 🙂

gmail has a new trick.

Logging in to gmail this morning, I noticed something that hadn’t caught my attention before. I had a shipment notification from Amazon, and it looked like this:

gmail: package tracking


Complete with a little “track package” link, which did the right thing. Nifty.

Getting down to the wire. (Google Reader)

Ok, I know that I’ve posted about this before, but now that July 1st is looming on the horizon, I figured maybe some of you have already made the leap elsewhere and might want to share what you’ve chosen as your Google Reader replacement.

So, speak up! Guide me! Save me from creating a dozen accounts and trying out different services. 🙂

Ask OS X typography geeks: Best font manager?

For a wide variety of reasons, I am starting to have need to be able to bulk install / activate and deactivate / remove fonts from my system. I’d like to be able to do this by project. (I’m working on Project $FOO, I need to make sure the fonts are installed. I’m no longer working on Project $BAR. I should remove the fonts.)

I haven’t used a font manager in 15 years, and I’m sure the field has drastically changed in that time. Any of you have any recommendations?